【PHP】Google Drive Client PHPでのエラー

Google Drive Client PHPをcomposerで再インストールした際に発生したエラーです。

環境

PHP Version 7.4.12

発生したエラー

Your Composer dependencies require a PHP version “>= 8.0.0”

Parse error: syntax error, unexpected ‘|’, expecting variable

ここのサイトを参考にすると上記のエラーはpsr / cacheがphp8以上対応になっているからのようです。そのため下記を実行してpsr / cacheのバージョンを下げる必要があります。

composer.jsonの修正

composer.jsonに「”psr/cache”: “^1.0″」を追加します。

{
    "require": {
        "google/apiclient": "^2.10",
        "psr/cache": "^1.0"
    }
}

ターミナルで下記を実行

composer update

参考にしていただければ幸いです!

Next-k
PHP

コメントする

メールアドレスが公開されることはありません。

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)